فروشگاه ساز ناپ کامرس - ناپ فارسی
شما هیچ موردی در سبد خرید خود ندارید

نیازمندی‌های سیستم ناپ‌کامرس

پلتفرم فروشگاه ساز ناپ‌کامرس (nopCommerce) با استفاده از آخرین و به روزترین فناوری‌ها و متدهای امنیتی ایجاد شده است، به همین دلیل به منظور نصب نسخه‌های گوناگون این پلتفرم، نیازمندی‌های سیستمی و فناوری باید برآورده شوند. در ادامه این نیازمندی‌ها به صورت مختصر معرفی خواهند شد.


سیستم‌عامل‌های پشتیبانی شده:

- سیستم عامل Windows 7 یا نسخه‌های جدیدتر.

- سیستم عام Windows Server 2008 یا نسخه‌های جدیدتر.


وب سرورهای (web servers) پشتیبانی شده:

- Internet Information Service (IIS) نسخه 7.0 یا نسخه جدیدتر.

- NET Core 2.2. برای ناپ‌کامرس نسخه 4.20 (دانلود).

- NET Core 2.1. برای ناپ‌کامرس نسخه 4.10 (دانلود).

- NET Core Window Server hosting. برای ناپ‌کامرس نسخه 4.00.

- ASP.NET 4.5 (MVC 5.0) و NET Framework 4.5. یا نسخه جدیدتر برای ناپ‌کامرس نسخه 3.90 یا قدیمی‌تر.


پایگاه داده‌های پشتیبانی شده:

- Microsoft SQL Server 2012 یا نسخه‌های جدیدتر.


مرورگرهای پشتیبانی شده:

- Microsoft Internet Explorer نسخه 9 یا جدیدتر.

- Mozilla Firefox نسخه 2.0 یا جدیدتر.

- Google Chrome نسخه 1.0 یا جدیدتر.

- Apple Safari نسخه 2.0 یا جدیدتر.


در صورتی که قصد دریافت نسخه‌های به همراه کد منبع (Source Code) پلتفرم ناپ‌کامرس را دارید، به منظور ویرایش کدها به موارد زیر نیاز دارید:

- برای نسخه‌های 4.10 و جدیدتر، Microsoft Visual Studio 2017 نسخه 15.7 یا جدیدتر به همراه .NET Core SDK (دانلود).

- برای نسخه‌های 4.00 و قدیمی‌تر، Microsoft Visual Studio 2017 نسخه 15.3 یا جدیدتر به همراه .NET Core SDK (دانلود).